Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 12, 2026 - 19:00 CDT
Scheduled
SWIVEL is performing updates affecting clients connecting to SWIVEL Payments infrastructure via CU*Answers and MeridianLink tonight August 12, from 8pm-12am Eastern Time.
Posted Aug 11, 2026 - 16:10 CDT
This scheduled maintenance affected: Agent-Assisted Payment Channels (Payments by SWIVEL).