Welcome to the SWIVEL® Status Page.

Below you will find status information for each of SWIVEL's products and services.

SWIVEL Connectors - intermittent "unable to process" errors

Incident Report for SWIVEL

Resolved

SWIVEL engineers have confirmed that all systems are operational as of 10:25am central time.
Posted Feb 06, 2026 - 10:52 CST

Monitoring

The maintenance has been completed and SWIVEL Pay systems are back online.
Posted Feb 06, 2026 - 10:34 CST

Update

We are continuing to work on a fix for this issue.
Posted Feb 06, 2026 - 10:19 CST

Identified

SWIVEL engineering has identified the root cause and is preparing an emergency maintenance plan to address the issue. SWIVEL Pay will be offline for approximately 30 minutes while this fix is being applied.
Posted Feb 06, 2026 - 10:05 CST

Investigating

We are aware of clients experiencing intermittent errors when attempting to process transactions through connectors. SWIVEL Engineering is currently investigating.
Posted Feb 06, 2026 - 09:57 CST
This incident affected: Self-Serve (SWIVEL Pay), Staff-Assisted (Payments by SWIVEL), and Integrations (Connectors).