Welcome to the SWIVEL® Status Page.

Below you will find status information for each of SWIVEL's products and services.

Autopilot Portal - Intermittent connectivity issues

Incident Report for SWIVEL

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 09:27 CST

Investigating

We are currently investigating reports of intermittent functionality loss within the Autopilot portal, including Search and Payment Submission functionality.
Posted Feb 13, 2026 - 09:04 CST
This incident affected: Staff-Assisted (AutoPilot Portal, Payments by SWIVEL).