Welcome to the SWIVEL® Status Page.

Below you will find status information for each of SWIVEL's products and services.

SWIVEL Pay Unable to Process Apple Pay Payments

Incident Report for SWIVEL

Resolved

This incident has been resolved. Apple Pay payments are now processing normally.
Posted Mar 26, 2026 - 12:42 CDT

Update

We are continuing to work on a fix for this issue. ACH and Card flows are still operational.
Posted Mar 26, 2026 - 02:21 CDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 26, 2026 - 02:19 CDT

Update

We are continuing to work on a fix for this issue. ACH and Card flows are still operational.
Posted Mar 26, 2026 - 02:16 CDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 26, 2026 - 02:15 CDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 26, 2026 - 02:14 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 26, 2026 - 02:13 CDT
This incident affected: Self-Serve (SWIVEL Pay).