Welcome to the SWIVEL® Status Page.

Below you will find status information for each of SWIVEL's products and services.

AWS Outage

Incident Report for SWIVEL

Resolved

SWIVEL services impacted by the AWS outage are now working as expected.
Posted Oct 20, 2025 - 15:48 CDT

Identified

We are seeing some intermittent issues with several of our systems due to some ongoing outages with Amazon Web Services.
Posted Oct 20, 2025 - 09:41 CDT
This incident affected: Self-Serve (SWIVEL Pay), Card Processor (SWIVEL Card Processing), and Staff-Assisted (Payments by SWIVEL).